How to update the missing System Engine properties in comstore?
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How to update the missing System Engine properties in comstore?

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Article ID: 20597

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Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Server Automation CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Description:

When the System Engine properties are missing from the comstore, the System Engine fails to start with the error 'Unable to Find Manager in Database'.

Diagnosis:

  1. System Event Viewer records the following errors "Cannot connect to the CAMDB. The Severity Propagation Engine cannot initialize. Terminating"

  2. Check the System Engine Properties in the Comstore file. You can save the comstore using the command 'ccnfcmda -cmd getconfigstore -fi <path to save the file>'

  3. System Engine on DSM Explorer shows the error 'Unable to find Manager in database'

  4. DSM Logs (TRC_SystemEngine*.log) shows the following errors

    • CFPlugin::init: --- initialising plugin:engine args: engine ---

    • CFPlugin::getSettings: entered

    • API call:GetParameterValue(itrm/common/caf/plugins/engine, plugindll,<pszParameterValue>, 255, NULL)

    • GetParameterValue(itrm/common/caf/plugins/engine, plugindll, ..., NULL)

    • returns CCNF_PARAMETER_NOT_FOUND

    • CFPlugin::getSettings: engine: plugindll property is blank - can't do anything

    • CFPlugin::getSettings: returned: false

    • CFPlugin::init: engine: user:

    • CFPlugin::init: returned: false

    • CFPlugins::GetPluginState: plugin:SystemEngine state: stopped

Note: For a similar error 'Unable to Find Manager in Database' please look at the technical document TEC428833 as well.

Solution:

Open the command prompt on the Domain Manager and execute the following commands in sequence:

  • Caf setprop SystemEngine communicable 1

  • Caf setprop SystemEngine dependencies "ccnfagent cfnotsrvd"

  • Caf setprop SystemEngine description Engine

  • Caf setprop SystemEngine enabled 1

  • Caf setprop SystemEngine enabledisplayondesktop 0

  • Caf setprop SystemEngine hidden 0

  • Caf setprop SystemEngine installed 1

  • Caf setprop SystemEngine instancename SystemEngine

  • Caf setprop SystemEngine killable 1

  • Caf setprop SystemEngine loadonstartup 1

  • Caf setprop SystemEngine maxinstances 1

  • Caf setprop SystemEngine maxrestarttime 3600

  • Caf setprop SystemEngine maxrestarts 3

  • Caf setprop SystemEngine messagetimeout 60

  • Caf setprop SystemEngine pipeconnecttimeout 120

  • Caf setprop SystemEngine plugindll cfPlugin

  • Caf setprop SystemEngine pluginpassword""

  • Caf setprop SystemEngine pluginusername""

  • Caf setprop SystemEngine restartifdied 1

  • Caf setprop SystemEngine runaselevatedadmin 0

  • Caf setprop SystemEngine runascurrentuser 0

  • Caf setprop SystemEngine runasservice 0

  • Caf setprop SystemEngine runonce 0

  • Caf setprop SystemEngine setcreds 0

  • Caf setprop SystemEngine startuptimeout 120

  • Caf setprop SystemEngine stoppable 1

Restart the CAF service using the command CAF STOP and CAF START.

Environment

Release: UASIT.99000-12-Asset Intelligence
Component: