Delete project Job not starting
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Delete project Job not starting

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Article ID: 205968

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When a user marks a project for deletion, the delete process / job is not executed.

Cause

This can happen if the Delete Projects job (Now renamed to Delete Investments and Time Reporting Periods) is in cancelled status. It's possible an upgrade cancelled this scheduled job, as sometimes when jobs are updated as part of the upgrade, any scheduled instances of those jobs get cancelled and have to be recreated. (See Review Cancelled Jobs After Upgrade.)

Note: There is no out of the box process that will delete projects / investments, this is a job in the system.

Resolution

Create a new scheduled instance of the job. Below are the steps to schedule the job to run every day at 2:00 am.

  1. Go to Home -> Reports and Jobs
  2. Click on the Jobs tab 
  3. On the Available Jobs page click on job: Delete Investments and Time Reporting Periods
  4. Under Parameters leave 'Delete Marked Investments with Timesheet and Transaction Data' unchecked (unless you want to delete projects that have timesheet and transaction data.)
  5. Under When, check 'Scheduled'
  6. Click Set Recurrence
  7. Scroll down to the bottom and select the radio button next to Use UNIX crontab entry format
  8. Enter 0 2 * * * in the crontab text field to have the job run every day at 2:00 am 
  9. Click Save and Return (Note the recurrence here will say Run Once still, but once you click Submit it will be updated as expected)
  10. Click Submit

You can also run an immediate run of the job to catch up on projects/investments waiting to be deleted.