Agent non-responsive
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Agent non-responsive

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Article ID: 205901

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent Autosys Workload Automation

Issue/Introduction

While trying to autoping an agent, the command hangs and eventually fails.
Jobs are stuck in STARTING state. 

The below errors from the agent transmitter log provides evidence of a communications issue.

12/31/2020 07:59:36.868-0700 5 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannelLogHelper.logConnectionAttempt[:75] - Attempting to open conversation to <AutoSysInstanceName>@<AgentMgrId>:7507 using plain socket
12/31/2020 07:59:36.910-0700 1 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannel.a[:1202] - Error connecting to<AutoSysInstanceName>:

cybermation.library.communications.CybConversationConnectBindException: Cannot assign requested address (Bind failed)
at cybermation.library.communications.CybConversation.<init>(CybConversation.java:274)
at cybermation.library.communications.CybConversation.<init>(CybConversation.java:174)

 

An agent can also become Inactive with errors in the transmitter log such as:

04/06/2025 17:56:02.053+0000 1 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannel.a[:1202] - Error connecting to <AgentMgrId>:

cybermation.library.communications.CybConversationConnectBindException: Address already in use (Bind failed)
at cybermation.library.com
munications.CybConversation.<init>(CybConversation.java:274)
at cybermation.library.communications.CybConversation.<init>(CybConversation.java:174)

Environment

Component : CA Workload Automation System Agent
Operating System : Linux

Cause

Ephemeral Port Exhaustion

Resolution

Reboot the agent server resolves the issue.