When installing the CA IAM CS (JCS) on Linux and selecting the "Remote Legacy Connector Server (C++) Management" option, you may encounter connectivity issues with the CCS on Windows. Users often report the following error:
"The server credentials provided are invalid. A connection to the server could not be established."
This article provides the steps to resolve this connectivity issue when firewall rules and hostname resolution are confirmed to be correct.
Identity Manager 14.5
By default, the CCS on the Windows server listens only on the loopback IP address (localhost). To allow connections from a Linux JCS host, you must configure the Urls parameter in the Windows registry to include the accessible IP address or hostname.
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComputerAssociates\slapd\im_ccs\CurrentVersionUrls key.Urls value to include the external hostname/IP address as follows:ldap://localhost:20402 ldaps://localhost:20403ldap://localhost:20402 ldaps://localhost:20403 ldap://<hostname>:20402 ldaps://<hostname>:20403 (Replace <hostname> with the actual CCS Windows hostname).Important: You must maintain ldap://localhost:20402 and ldaps://localhost:20403 in the Urls value. Removing these may cause the C++ Connector Server to enter an unstable running/stopping state.
If editing the registry for the im_ccs URLs be sure that you keep ldap://localhost:20402 ldaps://localhost:20403 as part of the value otherwise the C++ Connector Server may not run properly and continuously enter a running/stopping state, see document C++ Connector Server (im_ccs) Keeps Stopping/Restarting
To speak with a customer representative or a Support Engineer see . Scroll to the bottom of the page and click on your respective region.