Blank report or Access denied: Unable to open report of running job
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Blank report or Access denied: Unable to open report of running job

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Article ID: 205796

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Report not available for active job . This shows in two ways:

  1. Blank report is displayed

    Some users cannot see job reports while the job is running. After the job has ended, the job report is available. What can be the reason? It seems that UC4 admins with permission to all objects can see the job reports on active jobs, some users with permissions only to their job pool can not. Maybe this has something to do with the defined authorizations or privileges ?

  2. A user is not able to open the report of an active job. If SECURITY_AUDIT_FAILURE is active in the client, an administration will see this is due to a missing execution privileges:

    12/28/2020 04:34:13 PM
    U00004519 Access violation details: Used filter: 'LOGIN/LOGIN.WIN01//////' .
    12/28/2020 04:34:13 PM
    U00004506 Access violation: User: 'TEST/TEST' Object: 'LOGIN.WIN01' Access: 'X' Reason: No right found in authorization group '1'.

    X authorization on a login object is required for viewing reports on a running job

    Attempting to access the running job from Client 0 will show an error like:

    Version 21.0: The Automation-Engine is not configured correctly for using the external password.

    Version 12.3: Login object 'LOGIN.OBJECT' for Agent 'AGENT_NAME' on platform 'OS TYPE' was not found.

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Cause

There are two ways that a report is checked in Automic Automation:

1) If the task has finished, and the user opens the Report, all job details have been transferred from the agent to database and the user who has the "Open Report" permission for that job can read the Open and Read the Report because it is fully on the database.  The Open Report option at this point does not require login object information because it is done through a SQL Select statement against the database.

2) If the task has NOT finished (is active), then a live preview of the report is done where the user attempting to open the report is going out the agent to get the information.  This requires a login objects since this in and of itself is considered a task.  Because of this, the user requesting to open the report is executing a task and needs to have Authorization to execute a task with the login object that has access to the job report.

Resolution

The way to resolve this is to give users and/or usergroups "X" permissions on the login object that is used in the job.

When attempting to view the report of a running job from Client 0, a login object can be created with the same name as the login object in the working client as long as the permissions are correct.

This was mistakenly identified as a bug fixed in a previous version; but has since been reviewed and is considered as designed.  Please see the info in the "Cause" section above.