Fail to upgrade UIM from 9.02 to 20.3.2

book

Article ID: 205755

calendar_today

Updated On:

Products

CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

when we are upgrading the UIM version from 9.0.2 to 20.3.2 upgrade failed.

From Installation log:-

=================

2020-12-25 12:45:43,558 ERROR impl.UIMServerConfigureController:run:477 [Thread-44]  - NimException caught
(6) permission denied, Failed to communicate with probe 'automated_deployment_engine' in the allotted time of 300 secs.

 

Environment

Release : 20.3

Component : UIM - INSTALL

Resolution

Follow the  below Step:-

Cancel the upgrade

launch Infrastructure Manager

Make sure you have Java_jre 2.02 or later in the archive. ( updated 9 July 2020 )

Stay logged into IM.

Start the upgrade again.

Watch ADE to turn red and the state change to error.

When this happens, from IM, go to the archive and deploy java_jre 2.02 or later to the primary UIM while the upgrade appears to be waiting on ADE.

When it finishes installing, stop the ADE probe on the primary from Infrastructure Manager, then active ADE probe. It should get a port and PID and turn green.

If you did this fast enough, the upgrade should now continue past ADE and you should see the percent completed increasing.

Installation will complete without any problem.