search cancel

Fail to upgrade UIM with ADE error

book

Article ID: 205755

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When we are upgrading the UIM version from 9.0.2 to 20.3.2 (or from 20.3.0 to 20.3.3, or 20.3.3 to 20.4), the upgrade failed.

From the uim installation log:

======================

2020-12-25 12:45:43,558 ERROR impl.UIMServerConfigureController:run:477 [Thread-44]  - NimException caught
(6) permission denied, Failed to communicate with probe 'automated_deployment_engine' in the allotted time of 300 secs.

Environment

Release : 20.3

Component : UIM - INSTALL

Resolution

Follow the steps below:

  1. Cancel the upgrade
  2. Launch Infrastructure Manager
  3. Make sure you have java_jre 2.02 (java_jre 2.09 if upgrading to UIM 20.4) or later in the Primary hub local archive. 
  4. Stay logged in to IM.
  5. Start the upgrade again.
  6. Watch ADE turn red and the state changes to error.
  7. When this happens, from IM, go to the archive and deploy java_jre 2.02 (java_jre 2.09 if upgrading to UIM 20.4) or later to the primary UIM while the upgrade appears to be waiting on ADE.
  8. When it finishes installing, stop the ADE probe on the primary from Infrastructure Manager, then active ADE probe. It should get a port and PID and turn green.
  9. If you did this fast enough, the upgrade should now continue past ADE and you should see the percent completed increasing.

Installation should then complete without any further problems.