Spectrum cannot be added as a data source in CAPC

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Article ID: 205655

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Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading Spectrum and CAPC, I cannot add Spectrum as a data source as CAPC cannot talk to Spectrum.

 

Cause

CA Spectrum and CA PM integration breaks after CA Spectrum upgrade. This happens when SSL is enabled and CA Spectrum is connected to CA PM using https.

.

Environment

Release : 10.4

Component : Spectrum Core / SpectroSERVER

Resolution

Verify whether SSL is enabled on the OneClick web server host in the CA Spectrum environment.

If so, verify that the "axis2.xml" file is updated with HTTPS protocol and appropriate port number.

Follow these steps:
Open the "axis2.xml" file in an editor from "$SPECROOT/tomcat/webapps/axis2/WEB-INF/conf".
Locate the following section in axis2.xml:
class="org.apache.axis2.transport.http.AxisServletListener">
8080

Change the section as follows:
class="org.apache.axis2.transport.http.AxisServletListener">
8443

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/spectrum/10-4/integrating/ca-performance-management-and-ca-spectrum/troubleshooting-ca-spectrum-and-ca-performance-management-integration.html