CA Service Point integration with Service Catalog
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CA Service Point integration with Service Catalog

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Article ID: 205567

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Installed Service Point but ca service catalog offerings are missing:

1. Stopped the CA Service Management Search Server service and update dates with this query:

update usm_offering set date_available='2065-12-16 00:00:00.000' where offering_id=10229

Renamed "C:\Program Files\CA\SC\CASearchServer\elasticsearch-2.1.1\data\ca_es_cluster\nodes\0\indices"; for example, rename it from indices to indices-save01

Recreated the "indices" subdirectory; that is, create "C:\Program Files\CA\SC\CASearchServer\elasticsearch-2.1.1\data\ca_es_cluster\nodes\0\indices".

Started services and then ran C:\Program Files\CA\SC\CASearchServer\search\bin\pdm_es_initial_load.bat

Observation from the log:

 Line 1151: [12:24:45,699][ERROR][importer.jdbc.context.standard][pool-19-thread-1] at fetch: com.microsoft.sqlserver.jdbc.SQLServerException: 'concat' is not a recognized built-in function name.
 Line 1166:  at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:216) ~[sqljdbc4-4.0.jar:?]

Attached the logs initial_load.log and output for the query excuted. 

 

2. In CA SDM login an administrator.

Navigate to Administration, select xFlow Interface --> Service Point ---> Configurations.

Select a configuration from the configuration list, and click Edit.

From the Service Catalog drop-down list, select YES to show or NO to disable/enable the catalog featured offerings and requests in Service Point.  

Click Save.

3.Verified the folder exists: C:\Program Files\CA\SC\CASearchServer

 

Environment

Release : 17.X

Component : XFLOW INTERFACE FOR SDM

Cause

There are missing fields in the MDB database which were not created during the upgrade procedure.
After verifying the Service Desk Manager STDLOG, it shows that the MDB tables 'usm_configurationand' and 'usm_contact_domain_role' have the "id" field missing and Missing Entry in al_cdb_configurationparameter : 

SELECT * FROM al_cdb_configurationparameters where configkey='slcm.hostname'

Resolution

Check both the incidentMS.log: and Initial_load.log

if this error is present in the incidentMS.log 

Error fetching usm_configuration data.

com.ca.casm.exception.CasmBaseException: Error : AHD04199: unexpected error with the database contact your administrator.

and this is present in the Initial_load.log

[10:58:33,971][INFO ][loader.source ][main] Checking whether Service Catalog is installed in this Deployment.
[10:58:34,112][INFO ][loader.source ][main] Status of Service Catalog installation :
[10:58:34,112][INFO ][loader ][main] Skipping catalog

#Followed these below troubleshooting steps :
1) access ElasicSearch server through Chrome Addon  and deleted all the indexes. 
2) Stopped Search Server. 
3)Take the backup of al_cdb_configurationparameters
4) Added the missing table entry: 

USE [mdb]
GO

INSERT INTO [dbo].[al_cdb_configurationparameters]
([componentkey]
,[machinename]
,[configkey]
,[configvalue]
,[productcode]
,[last_update_date])
VALUES
('ITSM','common','slcm.hostname','Catalog_Real_hostName',9,1552577972583)
GO


5)Build meta data now: pdm_es_build_index_metadata.bat
C:\Program Files\CA\SC\CASearchServer\search\bin> pdm_es_build_index_metadata.bat
6)Build Initial Load: 
C:\Program Files\CA\SC\CASearchServer\search\bin>pdm_es_initial_load.bat

Then complete 

The below database queries will create the missing "id" field and resolve the problem:

ALTER TABLE [dbo].[usm_configuration]
ADD [id] INT IDENTITY (1, 1) NOT NULL;

ALTER TABLE [dbo].[usm_contact_domain_role]
ADD [id] INT IDENTITY (1, 1) NOT NULL;

After running the above queries, recycle the Service Catalog, Service Desk Manager and xFlow services.

 

Additional Information

https://knowledge.broadcom.com/external/article?articleId=205022 & https://knowledge.broadcom.com/external/article?articleId=194399