Many options are greyed out in the local Java console after installing Symantec Protection Engine 8.2
search cancel

Many options are greyed out in the local Java console after installing Symantec Protection Engine 8.2

book

Article ID: 205484

calendar_today

Updated On:

Products

Protection Engine for NAS Protection Engine for Cloud Services

Issue/Introduction

After install or upgrade to Symantec Protection Engine (SPE) 8.2, you notice a high percentage of the options in the local Java based web console are now greyed out.

Environment

Release: 8.2

Component: Java console

Cause

This is by design. Protection Engine 8.2 has a new back end scanning engine that supports different configuration options than the older engine in SPE 8.0 and earlier. The Java console is in the process of being retired, and was not comprehensively updated for the new release. 

Resolution

To configure SPE 8.2 via the UI, consider enrolling the scanners in the SPE centralized cloud console. It is updated to reflect the changes in the back end engine. For details about the centralized console, please see the Help topic Assets, scanners, and the scanner groups.

See also Enrolling the scanners with the centralized console and Onboarding Scanners


If enrollment in the centralized console is not possible, all active settings can be managed in "Core server only" mode via the command line utility xmlmodifier. For details about core server only mode, see the Help topic About the Core server only mode. For details about the xmlmodifier tool and command syntax, see the xmlmodifier Online Help. Inactive parameters cannot be modified with the xmlmodifier.

Additional Information

Full list of inactive parameters with SPE 8.2

configuration.xml

<EnableSubCategoryDescriptionResp value="false"/>  
<EnableContainerEngineNameResp value="false"/>   
<MalformedContainer enabled="false" interval="1" threshold="2"/>
<MailPolicy enabled="false" interval="1" threshold="2"/>  
<InsightDetected enabled="false" interval="1" threshold="2"/> 
 


policy.xml

All parameters under AntiVirusScanning tag are inactive. 
InsightCSCAT and InsightNASCAT are inactive parameter. 
<KeepConnectionOpen value="true"/>    
<BackendNetworkTimeout value="30000"/>    
<ExonerationNetworkTimeout value="30000"/>   
<ConvictionNetworkTimeout value="0"/>     
<SourceIPExclusionList>  
<SourceURLExclusionList> 
<TrustedCAFilePath value=""/>  
<ThresholdSecurityRating value="4"/> 
<ServerURL value="https://mobinsight.symantec.com/miqs/v1/insight?sha2="/>  
PartnerKey parameter is inactive.
<VerifyPeer value="true"/>   
<QueryTimeOut value="30"/>  
<ScanTimeOut value="5000"/>  
<FileSizeExclusionThreshold value="102400000"/> 
All parameters under CacheSettings tag are inactive. 
All parameters under ThreadPool tag are inactive. 
<InsightActionPolicy value="2"/>  
<APKReputationActionPolicy value="1"/> 
FileRepairedNotificationText is inactive parameter. 
APKFileDeletedNotificationText is inactive parameter. 
 


filtering.xml

<DecEngines value=""/>          
<MaxInMemoryFileSize value="256"/>       
<MaxExtractTime actionpolicy="1" value="180"/>    
<DecFileSize value="50"/>         
<EnableMSOfficeCRD value="true"/>       
<SuppressOfficeFormatEncryption value="false"/>     
All parameters under MalformedContainersHandling tag are inactive. 
<DenyPartialMIME actionpolicy="1"/>     
<EnableEnhancedContainerHandling value="true"/>  
All parameters under Options tag are inactive. 
All parameters under EmailAttribute tag are inactive. 

 

Example: 

Th Insight Policies radio button options correspond to <InsightActionPolicy value="2"/>  in file policy.xml.