When viewing reports within Identity Governance, no options appear in the dropdown menu. This issue occurs after ETL data capture, often accompanied by the error message: "Reports Loaded to the Report Server successfully, but errors while updating datasource."
This article details the steps to resolve authentication connectivity between the Identity Governance environment and the JasperReports Server.
Identity Governance 14.x
The error occurs due to a breakdown in the authentication token handshake between Identity Governance (IG) and the JasperReports Server. This typically happens when the token has expired or is mismatched following environment updates.
ig.properties and ig.jks files from: /opt/CA/wildfly-ig/standalone/deployments/eurekify.war/WEB-INF/classes/webapps/<your-webapp-name>/WEB-INF/jasperserver-pro/config/JasperKeyGen folder from a standard Identity Manager (IM) admin tool instance to your vApp and repeat the token regeneration steps above.For further information, see documentation Regenerate a Token for Authentication