Unable to generate a certificate signing request (CSR) after upgrade to 10.7.4
search cancel

Unable to generate a certificate signing request (CSR) after upgrade to 10.7.4

book

Article ID: 205415

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

After generating a new Certificate Signing Request (CSR) in Administration > Certificates the text area which should display the CSR data is empty.

Environment

Release : 10.7.4-13

Component :

Cause

This is a known issue in the 10.7.4 release.

Resolution

Version 10.7.5 or later:

This issue is resolved by upgrading to version 10.7.5 or later.

Version 10.7.4 and earlier:

This issue is resolved by applying patch 10.7.4-285 as follows:

  1. Log into the admin command line via ssh or putty
  2. Run the patch list command to confirm that patch 10.7.4-285 is accessible
    smg [10.7.4-13]> patch list
    ...
    sms-appliance-patch.x86_64            10.7.4-285             symrepo_smg_patches​
  3. Install patch 10.7.4-285 by running the patch -p 10.7.4-285 install command
    smg [10.7.4-13]> patch -p 10.7.4-285 install​

Workaround

If the patch cannot be immediately installed, a workaround  is to generate the certificate signing request (CSR) on another system (either Windows or Linux) and have the certificate signed by your CA. Once you have the signed certificate, you can import the certificate into Messaging Gateway (SMG) by following the instructions in the document:

Install Certificate Authority signed certificates without a generated Certificate Signing Request

This document explains how to import a CA certificate without generating a CSR on SMG, by combining the private key (generated when you generated the CSR) and the CA signed certificate in a single file prior to importing into SMG.

(NOTE: There are two sections to the document, one for private keys with a passphrase and one for private keys without a passphrase. Depending on your procedure to generate the CSR, you may or may not have to remove the passphrase.)