Randomly getting "All Views Suppressed" error when trying to view devices
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Randomly getting "All Views Suppressed" error when trying to view devices

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Article ID: 205340

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

We got an 'All Views Suppressed' error while trying to troubleshoot a P1 issue. This has happened a few times in the past month here as well.  Need some help determining what is causing this and preventing it.  T

Environment

Release : 20.2

Component : CA Performance Center

Cause

The issue only occurred when drilling back from Spectrum. It is a switch in Spectrum but it is classified as a server in CAPC.

So what is occurring is Spectrum is using a URL for a Switch device page to access CAPC and since its classified as a server in CAPC you get the error "All Views Suppressed"

Resolution


You need to do is classify these devices switches in CAPC since they are switches in Spectrum. In your /opt/IMDataAggregator/data/custom/devicetypes/DeviceTypes.xml in the Data Aggregator add/change:

Add or update the switch section if you have one to add this OID to sysObjectID DeviceTypes.xml:

<Switches>
  <sysObjectID>1.3.6.1.4.1.4413.1.2.1.2.5</sysObjectID>
</Switches>

Save the file and then using a discovery profile rediscover the device in the GUI. This should update the Device Type in CAPM to switch.

Link do documentation on changing device types in CAPM

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/20-2/building/manage-devices/override-device-types.html