Can't install CABI 7.1.1 on linux: Incorrect Application Server Status
search cancel

Can't install CABI 7.1.1 on linux: Incorrect Application Server Status

book

Article ID: 205319

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Spectrum

Issue/Introduction

I cannot install CABI Server 7.1.1 standalone on a Linux box

 

The extract of the install log shows 2 errors:

 

2020-12-11 15:20:43 ERROR ValidateDbServer.appServerError():473 - ============= APPSERVER ERROR MESSAGE================
2020-12-11 15:20:43 ERROR ValidateDbServer.appServerError():477 - Pre install check failed with the folloeing error.
2020-12-11 15:20:43 ERROR ValidateDbServer.appServerError():478 - -1 : Incorrect Application Server Status
2020-12-11 15:20:43 ERROR ValidateDbServer.appServerError():477 - Pre install check failed with the folloeing error.
2020-12-11 15:20:43 ERROR ValidateDbServer.appServerError():478 - -1 : Unsupported application server type
2020-12-11 15:20:43 ERROR ValidateDbServer.appServerError():481 - =============APPSERVER  ERROR MESSAGE END ================

 

 

Environment

Release : 20.3

Component : UIM - CABI

Cause

First error (in yellow) is due to the fact that tomcat was running during the installation. It must be stopped.

2020-12-11 15:20:41 ERROR ValidateTomcat.checkTomcatStatus():308 - Tomcat is not in stoppped state

 

Second error (in green) is due to an improper handle of a thrown exception of the first error. The error is not occurring during decryption but captured in the same block.

2020-12-11 15:20:41 ERROR ValidateAppServer.validateAppServer():391 - Exception found while decrypting the supported AppServer versions

 

These errors are showed during DB validation because every phase checks, before proceeding, if previous phase (App Server validation in this case) dumped any errors in /tmp/CAJaspersoftAppserverLogFile.txt.

 

2020-12-11 15:20:41 ERROR CABIUtil.printCABIException():109 - ErrorCode : 16106   ErrorMessage : Incorrect Application Server Status

2020-12-11 15:20:41 ERROR CABIUtil.printCABIException():109 - ErrorCode : 16101   ErrorMessage : Unsupported application server type

2020-12-11 15:20:41 INFO  ValidateAppServer.logerrors():281 - CAJaspersoftAppserverLogFile.txt file path is /tmp/CAJaspersoftAppserverLogFile.txt

...

...

2020-12-11 15:20:43 DEBUG ValidateDbServer.main():117 - Appserver error log file exists : /tmp/CAJaspersoftAppserverLogFile.txt

 

 

Resolution

Tomcat service needs to be stopped. Simply try to rerun the installation with tomcat stopped.