Twilio SMS configuration not connecting "Verifications was not found"
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Twilio SMS configuration not connecting "Verifications was not found"

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Article ID: 205308

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

We are using CA Identity Manager's out of the box integration with Twilio that sends OTP and verifies it.  This was working in 14.2 without SAML.

As part of this integration, we provide following details in CA Identity Manager -
URL - https://api.twilio.com/2010-04-01/Accounts
Account SID
Auth Token

See the following errors with no configurations changed at our end.

2020-11-17 12:00:17,395 ERROR [com.netegrity.ims.sms.impl.Twilio] (default task-14) Exception A JSONObject must begin with '{' at character 1 of <?xml versi
on='1.0' encoding='UTF-8'?>
<TwilioResponse><RestException><Code>20404</Code><Message>The requested resource /2010-04-01/Accounts/Verifications was not found</Message><MoreInfo>https://
www.twilio.com/docs/errors/20404</MoreInfo><Status>404</Status></RestException></TwilioResponse>
2020-11-17 12:00:17,395 ERROR [com.netegrity.ims.sms.impl.Twilio] (default task-14) Twilio notifyUser Exception java.text.ParseException: A JSONObject must b
egin with '{' at character 1 of <?xml version='1.0' encoding='UTF-8'?>
<TwilioResponse><RestException><Code>20404</Code><Message>The requested resource /2010-04-01/Accounts/Verifications was not found</Message><MoreInfo>https://
www.twilio.com/docs/errors/20404</MoreInfo><Status>404</Status></RestException></TwilioResponse>

Did anything change in the way this is configured?

Environment

Release : vApp 14.2 CP5 +SAML

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

URL for connection did change and "custom code" from the Twilio side will need to be enabled.  See resolution below.

Resolution

The URL for the Twilio SMS configuration should be: 
 
Example Only Link: https://verify.twilio.com/v2/Services/<Service SID>

Where the Service SID is the SID of the verify service created in your Twilio account.

Further information can be found at:

Recover the Password or LoginId with a One-Time Password with a Text or Voice Message

NOTE: Review sections titled as "Configuring Twilio" and "Configure SMS" for more details.

Contact Twilio Support to enable the “Custom Code” option in the “Code Customization” for your Verify Service.