Java exception error when trying to start SpectrumInsideView via OneClick
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Java exception error when trying to start SpectrumInsideView via OneClick

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Article ID: 205245

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

We tried starting InsideView via OneClick and saving the proper configuration, but when submitting "save", we are getting an exception on the page:

Environment

Release : 20.2

Component : Spectrum Core / SpectroSERVER

Cause

Proxy configuration was causing a Access Denied error in SpectrumIsideView logs. 

The log will output HTML and it is easier to read if saving the log as HTML file. Remove all log messages prior to the first <HTML> tag, save the file as HTML, and open in a browser.

Log snippet example. Remove the log messages up to the <html> tag: 


2020-12-10 15:45:21,406 - INFO - MainThread - Line no:626  : Getting all landscapes

2020-12-10 15:45:21,410 - CRITICAL - MainThread - Line no:428  : unable to get landscape details .. exiting response text : 
<html>

<head>

 

You will see message like this in the file, or on the page. 

Resolution

Local proxy policy was preventing access. 

Set no_proxy value to include hostname of the OneClick server. 

1. first review proxy environment

$ env | grep proxy

example:

 

2. add OneClick hostname to no_proxy: 

$ no_proxy="localhost, 127.0.0.1, <OneClickHost>"

$ export no_proxy

 

3. Verify value is set, check the new no_proxy value

$ env | grep proxy

 

4. Log back in to OneClick Administration > SpectrumInsideView (beta) and Start InsideView

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