Messaging Gateway virus definition update failing with 80840001
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Messaging Gateway virus definition update failing with 80840001

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Article ID: 205234

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Malware definitions are being downloaded but are not being loaded by the Messaging Gateway (SMG) Brightmail Engine

Brightmail Engine log

2021-03-15T09:20:24-04:00 (ERROR:29181.1999193856): [42120] SG Decomposer: LiveUpdate LUX error (80840001).
2021-03-15T09:20:24-04:00 (ERROR:29181.1999193856): [42115] SG Decomposer: Error during LiveUpdate.
2021-03-15T09:20:55-04:00 (ERROR:29181.1999193856): [42120] SG Decomposer: LiveUpdate LUX error (80840001).
2021-03-15T09:20:55-04:00 (ERROR:29181.1999193856): [42115] SG Decomposer: Error during LiveUpdate.
2021-03-15T09:20:55-04:00 (ERROR:29181.1999193856): [42120] SG Decomposer: LiveUpdate LUX error (80840001).
2021-03-15T09:20:55-04:00 (ERROR:29181.1999193856): [42149] SG Decomposer: Second virus definition update attempt failed with error code (80840001); first attempt failed with error code (80840001).  Continuing to use existing definitions.

Environment

Release : 10.7.3, 10.7.4

Cause

While a rare occurance, some malware engine updates can cause the Brightmail Engine to become unresponsive when attempting to load the new malware engine into the running process.

Resolution

This issue is currently under investigation.

A restart of the Brightmail Engine and MTA processes resolves this issue in the short term and the updated definitions are loaded from disk.

To restart the Brightmail Engine and MTA processes

  1. In the SMG Control Center go to Administration > Configuration 
  2. For each scanner
    1. Click the scanner hostname
    2. Check the Brightmail Engine and MTA services
    3. Click Stop
    4. When the services show as stopped select them again
    5. Click Start

Alternately the services can be restarted by running the service mta restart command from the admin command line (CLI)