Unable to update Finish Date on custom investment tasks if Task was Adjusted
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Unable to update Finish Date on custom investment tasks if Task was Adjusted

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Article ID: 205181

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When attempting to update a custom investment task finish date or ETC, the changes do not stick and the values go back to the previous values set. 

There is an assignment on the task, but no actuals or ETC are on the task

Steps to Reproduce:

  1. Log in to Modern User Experience (MUX)

  2. Navigate to Investments

  3. Filter for Investment

  4. Click Tasks

  5. Update the finish date of the task

Expected Result: Finish date is updated
Actual Result: Finish date reverts back to previous finish date.

Environment

Release : All Supported

Component : CA PPM SAAS PROJECT MANAGEMENT

Cause

If a task previously had time posted against it, and then the timesheet was adjusted where hours for the task were reduced to 0, the task is not able to be updated. 

To check if this is the cause:

  1. Go to the Timesheet Grid and filter on the resource(s) assigned to the task.
  2. Check to see if they have any adjustment timesheets during the time frame of the issue.
  3. If yes, view the resource's posted (original) timesheet, and see if the task existed on the timesheet.

Resolution

The one option would be to add an additional assignment to the task to make the ETC/Date editable. You can then adjust the finish date and add ETCs, and then remove the new resource from the task if needed. Dates and ETC will then still be editable. 

Additional Information

See also: