Availability reports in Spectrum Report Manager showing 0% availability
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Availability reports in Spectrum Report Manager showing 0% availability

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Article ID: 205136

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When running Availability reports in Spectrum Report Manager (SRM), the report is showing 0% availability for some devices even though the device are up and available in Spectrum.

A check of the $SPECROOT/tomcat/logs/stdout.log (Windows) or catalina.out (Linux) file shows the following error:

Dec 10, 2020 13:32:58.072 (SRM/EventPoller/Spectrum01) (SRM_Avail) - (ERROR) - Unable to properly process handler update.
  Domain: Spectrum01
  Handler: AvailabilityHandler

Environment

Release : Any

Component : Spectrum Report Manager

Cause

Checking the $SPECROOT/mysql/data/reporting directory on the SRM system shows many modelavailbucket* files not getting processed as they should.

Resolution

Restart tomcat on the SRM system.

Monitor the $SPECROOT/tomcat/logs/stdout.log (Windows) or catalina.out (Linux) file on the SRM system for the errors.

Monitor the $SPECROOT/mysql/data/reporting directory to ensure the modelavailbucket* files getting processed.

If the error persists, please open a case with Spectrum Support.