Not able to capture device configuration after migrating Spectrum from one system to another system
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Not able to capture device configuration after migrating Spectrum from one system to another system

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Article ID: 205110

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

After migrating Spectrum from one system to another, we are not able to capture a device configuration. We see the following error:

SPC-NCM-20007: Capture Running Script Returned Error [2]:  Could not open file 'C:\Users\spectrum\Desktop\LOG\report.txt' No such file or directory at E:/SPECTRUM/NCM/cache/script_0x4c9ed5_0x40f32a_cap_run line 110.

Environment

Release : 20.2

Component : Spectrum Network Configuration Manager

Cause

When Spectrum was migrated from one system to another, the user that owns the Spectrum installation was change from "spectrum" to another user.

The old server's owner was spectrum, so it may look like this is a custom script, pointing to the home folder for spectrum user.

There are no spectrum user on the new server.

Resolution

Modify the customer script for the new owner or create the folder for the old owner and set the permissions to grants rights for the new owner.