Unable to schedule replication to the specified server: The local credential username Domain\Username could not connect to the local server.
search cancel

Unable to schedule replication to the specified server: The local credential username Domain\Username could not connect to the local server.

book

Article ID: 205081

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

You started noticing that computer resources were no replicating from your Child SMPs to the Parent SMP. Things like "Last Configuration Request" date were out of sync since you tried to change your AppID account password over the weekend.

The NS logs on the parent SMP showed the following error:

Unable to schedule replication to the specified server (Server: child-01.example.com, Exception: Altiris.NS.Exceptions.AeXException: The local credential username Domain\AppIDaccount could not connect to the local server http://parent-01.example.com/Altiris/NS/
   at Altiris.NS.Replication.ReplicationJobHelper.<>c__DisplayClass12_0.<CreateReplicationJob>b__1(Exception ex, Int32 cur, Int32 total)
   at Altiris.NS.Utilities.ActionExtensions.RetryAction(Action action, Int32 retry, Int32 delay, Action`3 log)
   at Altiris.NS.Replication.ReplicationJobHelper.CreateReplicationJob(String jobId, String name, Guid serverGuid, String serverName, String serverUrl, WebServiceCredential destinationCredentials, WebServiceCredential sourceCredentials, ReplicationRuleCollection rules, ReplicationMode mode, ReplicationPriority priority, Boolean hierarchy)
   at Altiris.NS.Replication.Hierarchy.HierarchyRuleManager.CreateReplicationJob(String jobId, String name, HierarchyNodeItem node, ReplicationRuleCollection rules, ReplicationMode mode, ReplicationPriority priority)
   at Altiris.NS.Replication.Hierarchy.HierarchyRuleManager.ResolveRules(IItem item, HierarchyRuleScope scope, ReplicationMode mode, ReplicationPriority priority, HierarchyRuleCollection rules, HierarchyNodeItem node, Boolean isEvent, Guid hierarchyJobId)).
-----------------------------------------------------------------------------------------------------
Date: 12/14/2020 10:33:29 AM, Tick Count: 729185359 (8.10:33:05.3590000), Size: 1.57 KB
Process: AtrsHost (15540), Thread ID: 185, Module: Altiris.NS.Replication.Hierarchy.dll
Priority: 1, Source: HierarchyRuleManager.ResolveRules

Environment

ITMS 8.x

Cause

The customer had manually typed the AppID account on his Hierarchy Settings and the password was not valid/old one.

Resolution

In order to fix this issue, try the following:

1. On the Parent SMP, go to SMP Console>Settings>Notification Server>Hierarchy>Select the Child SMP>right-click>Edit

2. Make sure that you are using "Use application credentials" instead of "Use these credentials" in both places (or if you need to use a specific account, keep selected "Use these credentials" and retype the password)

3. After making the appropriate changes, run a differential replication from the Child SMPs to the Parent SMP and check the right information is replicated and no longer the error is present while replicating.