Errors in Spectrum Report Manager log file indicating issue with BOXI
search cancel

Errors in Spectrum Report Manager log file indicating issue with BOXI

book

Article ID: 205055

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The following error is seen in the $SPECROOT/tomcat/logs/stdout.log (Windows) or catalina.out (Linux) file ion the Spectrum Report Manager (SRM) system:

Nov 17, 2020 18:36:18.527 - Error while determining Crystal Only users. com.aprisma.spectrum.app.repmgr.exceptions.SRMException: BOXI login credentials incomplete.  Verify the following fields are specified in the Business Objects integration page:
BOXI Administrator Credentials (User, Password, Authentication Type)
BOXI CMS Location (Host and Port)

This installation of Spectrum was integrated with BOXI at one time but is now integrated with Jasper.

Environment

Spectrum Report Manager

Cause

The registry for the reporting database still contains a reference to BOXI

Resolution

NOTE: Starting from DX NetOps Spectrum 21.2.4, the default root password for MySql is "MySqlR00t". For DX NetOps Spectrum versions prior to 21.2.4, the default root password is "root". In the following MySql commands, replace <PASSWD> with the root password for your DX NetOps Spectrum version.

Follow the instructions outlines in knowledge article "Upgraded OC/SRM server install shows error message regarding CABI/BOXI server integration". 

If the issue persists after following the instructions in the above knowledge article, please do the following:

1. Log into the SRM system as the user that owns the Spectrum installation

2. If running Windows, start a bash shell by running "bash -login"

3. cd to the $SPECROOT/mysql/bin directory and enter the following command:

./mysql --defaults-file=../my-spectrum.cnf -uroot -p<PASSWD>-e "Update registry set isReportingReady=false;" reporting

4. Restart tomcat on the SRM system