Spectrum upgrade failed with database error in the post install log file
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Spectrum upgrade failed with database error in the post install log file

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Article ID: 205051

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Updated On:

Products

CA Spectrum

Issue/Introduction

The Spectrum upgrade failed with the following error in the post install log file:

Migration file dbsavefile.SSdb was not found or is not readable.
Backing up catalog and models to db_20181120,1.SSdb ERROR:
This application has been started using a Spectrum database which was not gracefully closed.
The application will now shut down to allow you to load and initialize a previously-saved good database.
SPC-DBS-20095: SSdbsave Error: Unable to open database.
** Error during backup to db_20181120,1.SSdb [email protected]

Environment

Release : Any

Component : Spectrum Core / SpectroSERVER

Cause

The SpectroSERVER process was not shutdown gracefully before running the install.

Resolution

If installing on a VM and a snapshot was taken before running the upgrade, re-image the system with the snapshot. Then, ensure all of the Spectrum processes are shutdown gracefully before running the upgrade.

If not a VM or there is no snapshot of the VM than if there is a SpectroSERVER database backup available from the previous install, coy the backup to a safe place and uninstall Spectrum. Then, us the dbsavefile.SSdb method to upgrade the database. Reference knowledge article "Database corruption error during post install of Spectrum".