Hard Allocation does not match Availability
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Hard Allocation does not match Availability

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Article ID: 205013

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

We have a resource with Availability of 2 hours. When we try to enter 2 hours for hard allocation for the user, it automatically reverts back to 1.82.

Environment

Release : All

Component : CA PPM PROJECT MANAGEMENT

Cause

This issue can happen if the availability was updated for the resource instead of changing the resource's calendar shifts to update the availability. Updating the resource calendar automatically updates the availability. 

Resolution

To change resource availability, update the resource's calendar shifts instead of directly updating availability.

To fix the impacted resource's availability:

  1. Go to Home->Resources, and click on the Resource
  2. Click on the Calendar tab for the Resource
  3. Select the check boxes next to the Mon, Tue, Wed, Thu, and Fri headers (or all working days for the resource)
  4. Click on the Set Shifts button
  5. If the shift hours don't equal 2 hours, update the shifts to equal that amount and click Save and Return
  6. Go back to the Properties tab for the resource, and change the Availability back to 2 (it will change to a different amount if the resource shifts and availability amounts were previously out of sync)