OneClick WebApp fails to launch due to firewall restrictions
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OneClick WebApp fails to launch due to firewall restrictions

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Article ID: 204960

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

The webtomcat WebApp is configured to use the default http port 9443 and to use port 8443 for SSL. However, we are not able to launch the WebApp.

As a test, we configured the WebApp to use the Linux default http port 8080 and we are able to launch the WebApp successfully.

Unable to launch the OneClick WebApp

Environment

All supported Network Observability DX NetOps Spectrum OneClick WebApp releases

Cause

Firewall rules are blocking TCP ports 9443 and 8443, which are required for WebTomcat and SSL communication.

Resolution

To properly resolve this take these steps:

  1. Identify the ports used by the WebApp (default 9443 and 8443).
  2. Verify connectivity using a test on an open port (e.g., 8080).
  3. Work with the security/network team to whitelist ports 9443 and 8443 on the firewall.

After opening these ports, the user will be able to launch the OneClick WebApp successfully.

Additional Information

 

SpectroSERVER and OneClick Web Server Communication Across Firewalls