PAM Client Stops After Authenticating
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PAM Client Stops After Authenticating

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Article ID: 204864

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Updated On:

Products

CA Privileged Access Manager (PAM) CA Privileged Access Manager - Cloakware Password Authority (PA)

Issue/Introduction

When a user logs into PAM through the PAM client, the client will stop with an error.

Looking at the Session logs, the authentication is successful, but the PAM client's log file (C:\Users\<User>\CA PAM Client\logs.log), have the following lines.
2020-12-09 11:44:42 DEBUG - Extracting C:\Users\<User>\xceedium\web\utils-win-32.dll     com.ca.xsuite.app.xbrowser.screenshooter.LibraryExtractor [SwingWorker-pool-1-thread-4]
2020-12-09 11:44:43 INFO  - java.lang.UnsatisfiedLinkError: C:\Users\EndUser\AppData\Local\Temp\jna-EndUser\jna4324072045736224468.dll: Access Denied     syserr [SwingWorker-pool-1-thread-4]

Environment

Privileged Access Management, any version

Cause

The access denied is coming from the end user's environment. This could be either a policy blocking dll files from being accessed in the Temp directory or could be an issue with the user's profile.

Resolution

Review the workstation's GPOs to see there is anything preventing access to Temp. It may also be resolved by deleting the user's profile and having them login to the workstation again to recreate it.