Startup of CA Dispatch receives DC203006L and DC391008 WARMSTART FAILED U3692 abend
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Startup of CA Dispatch receives DC203006L and DC391008 WARMSTART FAILED U3692 abend

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Article ID: 204789

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Updated On:

Products

Dispatch Output Mgmt

Issue/Introduction

During startup of a TEST  CA Dispatch system we received the following abend. We do not have the offloaded Journals necessary to perform the rollback processes, and we are looking for the best way to get CA Dispatch up and running again. 

** Messages seen in the CA Dispatch logs are as follows **

DSB7 DC390009 V1 STARTING IDMS-CV/DC INITIALIZATION                   
IDMS DC202001L STARTING WARMSTART                                     
IDMS DC202019L WILL ROLL OUT RUN UNIT ID  227038755                   
IDMS DC203006L UNABLE TO FIND BGIN/COMT CKPTS FOR ALL ACTIVE RUN UNITS
DSB7 DC391008 WARMSTART FAILURE - IOSTATUS=0008 - USER COMPLETION CODE=3962

Environment

Release : 11.7

Component : CA Dispatch

Cause

It would seem that the CA Dispatch journal file(s) have somehow been corrupted and Dispatch is unable to find/access the information that it needs off of a journal file in order to complete a successful warmstart. The DC203006 message and U3962 abend are documented as follows:

 

DC203006 - Unable to find begin or commit checkpoint for all active run units

Reason:
When starting CA Dispatch the WARMSTART task fails with U3962 abend and the DC203006 is displayed. This means that information is missing on the current Journal files.

Action:
The only way to recover is to use your offloaded journal tapes and do a rollback using DSEXBR08. Follow the rollback with the DSEXJFIX job to initialize the current journals.
For more information, see the Rollback section of the Backup, Restore and Recovery chapter in the Systems Programmer Guide.

 

U3962

WARMSTART routine failed.

When starting CA Dispatch, the WARMSTART task fails with U3962 abend and the DC203006 UNABLE TO FIND BEGIN OR COMMIT CHECKPOINT FOR ALL ACTIVE RUN UNITS.
The only way to recover is to use your offloaded journal tapes and do a rollback using DSEXBR08. Follow the rollback with the DSEXJFIX job to initialize the current journals.

Resolution

If you do not wish to perform, or are not able to perform the rollback process using DSEXBR08, the "Quick Fix" for getting CA Dispatch up and running again is...

- Execute the DSEXPFIX job to unlock the database files and reset the "in use" flags.

- Run DSEXJFIX with a symbolic setting of MIGRATE='LE' to initialize your existing journal files and clean up any corruption and/or fragmentation.

- Run DSEXDBAN (area='LT' Against ALL database areas) to do a database analysis and let you know if you have any broken chains in your IDMS database files.

- Restart CA Dispatch. 

 

NOTE

* Having broken chains in your IDMS database files can cause unpredictable results. Even for a TEST system, you will want to know what the integrity of your database files is.

* If you have broken chains in your database files, at some point you are going to need to address them.