sdgtw - the incident creation fails when UIM source alarm field is mapped with SDM category field
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sdgtw - the incident creation fails when UIM source alarm field is mapped with SDM category field

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Article ID: 204753

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When UIM source alarm field is mapped with SDM category field, the incident creation fails with the below error:

[pool-21-thread-3, sdgtw] Error while calling the createIncident of 'nimClient'java.lang.Exception: {"Error":{"ErrorCode":154,"ErrorMessage":"Exception occurred during operation createIncident","DetailErrorMessage":"Error setting attr 'category' on object 'cr:893193' to value 'ca servers' NOT FOUND ca servers","HTTPResponseCode":"INTERNAL_SERVER_ERROR","HTTPResponseCodeValue":500}}

Environment

Any release of sdgtw probe running on a supported configuration.

Cause

Issue is with Mapping between the fields in the UIM alarm (and the Default Value, the Custom Value) and the required fields in the ticket being attempted to create instance in CASDM.
 
Check the Field Mappings, path is as below:
Login to admin console  -> select sdgtw robot -> sdgtw probe -> CA Service Desk Manager -> Search for Field Mappings, you should see similar options as below:

Resolution

You would need to work with your Service Desk administrator to find out which fields in the SDM ticket must be provided and the supported values for these fields.  Then you would need to map the appropriate UIM alarm field to the corresponding CASDM ticket field in the field mappings you have defined in the CASDM connection profile.

In this case it was found out there was a typo in a string in custom value for category (which was predefined in SDM) which caused the issue: