ServiceNow Integration - Is serviceNow version Orlando supported in SOI 4.2?
search cancel

ServiceNow Integration - Is serviceNow version Orlando supported in SOI 4.2?

book

Article ID: 204732

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

When trying to add an instance of the SOI serviceNow connector to our Orlando install of serviceNow, we are getting an error:

2020-12-04 16:49:28.216 [ERROR] (qtp1320960914-116) com.ca.usm.ucf.servicenow.ServiceNowConnector  - Error invoking web service 'insert' operation for table 'incident'.  Retrying 1/3 ...

com.sun.xml.internal.ws.fault.ServerSOAPFaultException: Client received SOAP Fault from server: com.glide.processors.soap.SOAPProcessingException: Insert Aborted : Data Policy Exception:

            The following fields are mandatory: Service, Configuration item Please see the server log to find more detail regarding exact cause of the failure.

Environment

SOI 4.2

serviceNow = Orlando

serviceNow connector 4.6.0.60 and older

Cause

The current GA version of the serviceNow connector, 4.6.0.60, has been certified with serviceNow versions Madrid, London, and New York.

We have not tested the Orlando version and it may have schema changes that are not compatible with the 4.6.0.60 connector.

Resolution

Broadcom is working on adding support for serviceNow Orlando.

12.2020 - There is currently no ETA.

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/service-operations-insight-connectors/connectors/ca-soi-connectors-compatibility-matrix.html