hub qos queue growing after upgrade from UIM 8.x to UIM 20.x
search cancel

hub qos queue growing after upgrade from UIM 8.x to UIM 20.x

book

Article ID: 204724

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After upgrading UIM from 8.x to 20.x the primary hub get queue is not draining and it is accumulating data. 

Increasing bulk_size does not help.

The amount of data flow did not change since before the upgrade and no configuration change was done. 

Environment

Release : 20.3

Component : UIM - HUB

Cause

9.x hub postroute default configuration is updated automatically. 

Resolution

Upgrading from hub 7.x to 9.x may change the hub.cfg default configuration for postroute. 

 

Example:

 

Upgraded version settings

 

postroute_interval = 120

postroute_passive_timeout = 300

postroute_reply_timeout = 180

broadcast_on = no

hubs_update_interval = 300

hub_request_timeout = 120

 

 

Pre upgrade and changes made to current

 

postroute_interval = 30

postroute_passive_timeout = 30

postroute_reply_timeout = 60

broadcast_on = yes

hubs_update_interval = 600

hub_request_timeout = 30

 

to fix the issue restored the hub.cfg changes from pre-upgrade.