No data in Spectrum Performance View - Spectrum health view
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No data in Spectrum Performance View - Spectrum health view

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Article ID: 204710

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Updated On:

Products

CA Spectrum

Issue/Introduction

No data in the Spectrum Performance View - Spectrum health view 

After installed and configured the Grafana, no data is displayed for the Spectrum_health_View.json.

Environment

DX NetOps Spectrum 10.4.2.x / 20.2.x

Cause

There is no data in the influx spectrum database.

The following error was found in the $SPECROOT/insideView/SpectrumInsideView.log file:

2020-12-08 16:44:21,878 - CRITICAL - MainThread - Line no:444  : Exception occurred during Get Landscape Rest API. shut down triggered. :
2020-12-08 16:44:21,878 - ERROR - MainThread - Line no:445  : HTTPConnectionPool(host='lvntest000868', port=8080): Max retries exceeded with url: /spectrum/restful/landscapes (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f47d6200f28>: Failed to establish a new connection: [Errno 111] Connection refused',))
Traceback (most recent call last):
  File "urllib3/connection.py", line 157, in _new_conn
  File "urllib3/util/connection.py", line 84, in create_connection
  File "urllib3/util/connection.py", line 74, in create_connection
ConnectionRefusedError: [Errno 111] Connection refused

Incorrect OneClick hostname in the $SPECROOT/insideView/SpectrumInsideView.conf file:

Resolution

Supplied the correct OneClick hostname in the $SPECROOT/insideView/SpectrumInsideView.conf file, and stop/start the InsideView Configuration(beta) in the OneClick Administration web page.

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