Unable to edit Group Rule in Performance Management Performance Center UI
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Unable to edit Group Rule in Performance Management Performance Center UI

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Article ID: 204690

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

I was trying to remove some devices from a group membership rule. This rule was created years ago. When I try to edit the rule to remove a handful of devices that have been decommissioned, I'm receiving an error "Rule exceeds condition, sub-rule or value limits.  Rule cannot be edited."

The error in the UI looks like this.

Environment

DX NetOps Performance Management releases

  • r3.7.12 and newer
  • All r20.2.x releases

 

Cause

To many rules for new new non-Flash based web UI Manage Groups page to display.

Resolution

With the new non-Flash Manage Groups page there are now Global Attributes that control the number of Rules the UI is able to display.

This does not limit the number of rules able to be created but will limit the display of some Group Rules with large numbers of entries.

To resolve this we can modify these limits. To determine the value to set we need to run this query in the MySql netqosportal database on the Performance Center host.

  • From (default path) /opt/CA/MySql/bin run:

    ./mysql -uroot -p netqosportal -e "select itemid,ruleindex,compareindex,count(*) from rule_values group by 1,2,3 order by 4 desc limit 5;"

  • When prompted enter the password for the MySql database.
  • Make note of the highest value listed in the count(*) column.

To change the configuration and allow edit of these large rules:

  1. Go to the following URL in a browser tab:
    • http://<PC_HOST>:8181/pc/center/admin/debug
  2. Set the <PC_HOST> to the correct host name or IP address and log in using the system default admin user and it's password.
  3. Select the Global Attributes option.
  4. Find the RuleEditor.MaxOrValuesInCondition entry and raise the value just over the highest count(*) value from the DB query.
  5. Select the Update button found at the top and bottom of the page. Either one will work.

In the example that uncovered this the highest count was 1192 so the value was set to 1200. After this the Rules were able to be edited as needed.

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