ARD 3.0 to ALM 15.01 connectivity fails due to Authentcation Failure
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ARD 3.0 to ALM 15.01 connectivity fails due to Authentcation Failure

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Article ID: 204678

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Updated On:

Products

CA Agile Requirements Designer

Issue/Introduction

We recently upgraded from ALM 12.5 to 15.01, and enabled SSO on the ALM side. Ever since the change users are not able to export test cases directly from ARD to ALM.

They are getting an authentication error, and their credentials are not recognized. The users are able to authenticate to ALM using the ALM client, so we know the credentials are correct.

Environment

Release : 3.0

Component : AGILE REQUIREMENTS DESIGNER AGILE CENTRAL INTEGRATION

Cause

To help troubleshoot the issue, we turned on the ALM logging in the ARD Settings. 

 

The error logged by ARD is as follows:

2020-12-07 10:40:30,091 INFO  [default] [HP Application Lifecycle Management Log](GET) Request URL: https://hpalm.domain.com:8443/qcbin/authentication-point/authenticate
2020-12-07 10:40:30,488 ERROR [default] [c:\buildagent\tdm\agiledesigner\agiledesigner\restservicehelper.cpp:560] [HP Application Lifecycle Management Log]Qt Network Error (Qt error code: 204) Host requires authentication
2020-12-07 10:40:30,488 INFO  [default] [HP Application Lifecycle Management Log]Response URL: https://hpalm.domain.com:8443/qcbin/authentication-point/authenticate
2020-12-07 10:40:30,488 INFO  [default] [HP Application Lifecycle Management Log]Response HTTP Code: 401
2020-12-07 10:40:30,488 INFO  [default] [HP Application Lifecycle Management Log]ReturnedMessage: <html>
<head>
<meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
<title>Error 401 Incorrect credentials, login failed</title>
</head>
<body><h2>HTTP ERROR 401</h2>
<p>Problem accessing /qcbin/authentication-point/authenticate. Reason:
<pre>    Incorrect credentials, login failed</pre></p>
</body>
</html>

2020-12-07 10:40:39,574 INFO  [default] ------------------------- System Information----------------------
2020-12-07 10:40:39,575 INFO  [default] OS Version: Windows 10 (operating system version 10.0)
2020-12-07 10:40:39,575 INFO  [default] Build Cpu Architecture: x86_64
2020-12-07 10:40:39,575 INFO  [default] Current Cpu Architecture: x86_64
2020-12-07 10:40:39,575 INFO  [default] Kernel Type: winnt
2020-12-07 10:40:39,575 INFO  [default] Kernel Version: 10.0.18363
2020-12-07 10:40:39,576 INFO  [default] Machine Host Name: <HOSTNAME>
2020-12-07 10:40:39,577 INFO  [default] Product Type: windows
2020-12-07 10:40:39,577 INFO  [default] Product Version: 10
2020-12-07 10:40:39,577 INFO  [default] Byte Order: x86_64-little_endian-llp64
2020-12-07 10:40:39,577 INFO  [default] ProductName: Windows 10 (10.0)
2020-12-07 10:40:39,577 INFO  [default] ------------------------- Product Information----------------------
2020-12-07 10:40:39,577 INFO  [default] 3-0-000-11

Resolution

Reviewing the ALM Site Administration REST API Reference documentation for ALM 15.0 and later, we see when SSO is enabled, access to the ALM Site Administration via the RESTful API only supports API Key Authentication.

Currently, the ARD/ALM integration does not support API Key Authentication. This is most likely the cause of the authentication failures. Although, officially we do not support integration between ARD and ALM 15.0 and later, and therefore, this has not been tested by Broadcom.

Disabling SSO might provide a possible workaround, but we cannot guarantee this, because it's not supported nor tested.

 

As of 3.2, this has been incorporated in as a Feature enhancement package.

Additional Information

An Enhancement Request has been submitted to add ALM 15.0 with SSO support. The request can be tracked with Product Management via US718313, parented by F85504 (Edited by Les Dover 6/27/2022) and Master parented by F99634.