UIM False robot inactive alerts
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UIM False robot inactive alerts

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Article ID: 204662

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We recently upgraded to 20.3 and updated all hubs/robots to the latest version. Hub is 9.31 and robot is 9.32. After updating to 20.3 everything was fine but once we started upgrading our remote hubs we started getting false positive robot inactive alarms. What this means is the alarm would come in but the robot would still be accessible and you could open the probes on it. Is there a known bug with these versions?

Environment

UNIFIED INFRASTRUCTURE MANAGEMENT  Release : 20.3

OS: Windows server 2016

Component : UIMROB : UIM - ROBOT

Cause

There may be communication issues between the hub and the robots which attach to that hub. The hub will send check-ins or broadcasts to its robots, if a response is not received, then the hub will trigger a robot inactive alarm as it cannot communicate with the robot. Please provide log level 3 hub logs and controllers logs from the hub system, to Support along with log level 3 controller logs from one of the robots raising these false alerts.

Please provide these files to be in sync (time) and capturing the time period of a false alarm raised. In addition a screenshot of the alarm as well, this will help Support check the logs for this time period and confirm if there are communication errors between the hub to and from robot communication. You will also need the hub name / ip address and robot name / ip address. Please note: select 1 robot for troubleshooting.

Note that in some case, robot inactive alarms being issued can be caused by network delays (between hubs and robots).

Resolution

- Client found servers with the old robot triggers false positive robot inactive alerts when the hub is running the latest version. The fix was to update all robots.