Unable to Update Finish Date on Custom Investment Tasks due to Actual Thru Date
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Unable to Update Finish Date on Custom Investment Tasks due to Actual Thru Date

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Article ID: 204576

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When attempting to change a custom investment task finish date, the date reverts back to the previous date. No errors are displayed.

Task characteristics: No ETCs assigned, No Actuals logged, Status = Started, No task hierarchy defined

Steps to Reproduce:

  1. Log in to the Modern User Experience (New UX)

  2. Navigate to Investments

  3. Filter for investment

  4. Click Tasks

  5. Update the finish date of the task

Expected Result: Finish date is updated
Actual Result: Finish date reverts back to previous finish date

Environment

Release : All Supported

Cause

This can happen if the date is attempted to be changed to a date prior to the assignment(s) actual thru date. Even if there are no actuals for that particular task, if the resource(s) assigned to the task have posted time, this will generate an actual thru date for the assignment.

To check if this is the cause: 

  1. Click on the Assignments tab in the investment
  2. Add the Actuals Thru field to the column list
  3. Compare that date to the date you are trying to change the finish date to

Resolution

Since there are no actuals posted against the task, you can remove the resource assignment and add it back. This will clear the Actuals Thru Date and you can then change the task Finish Date.

Additional Information

See also: