RA Execution server is not reachable
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RA Execution server is not reachable

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Article ID: 204361

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

We are using Release Automation version 6.7.0.124, and we have an execution server. And since 2 days it is not reachable. We tried restarting the server, and in server level it shows it is up and in RA level it shows it is in offline status only.

We have validated with Network team, and everything is fine from their side. Kindly provide inputs on how to resolve the same.

Environment

Release : 6.6, 6.7

Component : CA RELEASE AUTOMATION RELEASE OPERATIONS CENTER

Cause

The error means that this execution server is connected to some other NAC.

2020-11-27T08:57:46.359+01:00 [ReverseConnectionWorker-1] INFO (com.nolio.nimi.comm.impl.NetworkConnectionManagerImpl:139) -Found existing connection to address [l*******/X.X.X.X:6600] for node [nid:es_****].

The above method means this NES is already connected to some other NAC in your environment. It is as per design a NES can't be connected to more than 1 NAC

Resolution


The way to resolve this is as below

Resolution one

1: Locate the NAC where it is connected and remove this execution server from there and than re-add it to the NAC you want to see it as online.

Resolution two 


The below steps will force to clear all connection data with any other NAC and should start a fresh.

  1. Stop the NES service
  2. Clean content of directory <NES InstallDir>\\activemq-dataes\LevelDB
  3. Start the NES
  4. You need to add the NES again to NAC via ROC.