All Devices show Unknown status and no data in DX NetOps Portal reports
search cancel

All Devices show Unknown status and no data in DX NetOps Portal reports

book

Article ID: 204310

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

All Devices in the DX NetOps Performance Management Portal web UI are showing an unknown status and no data is seen in reports.

All system components like the Data Aggregator (DA) and Data Collector(DC) are Green and Normal.

Data is being successfully polled and inserted to the database for reports.

The Data Collector, the Data Aggregator, and the Performance Center Portal systems have all had their processes restarted but the problem remains.

The following error is observed in the PCService.log files.

INFO   | jvm 1    | 2021/08/13 16:02:04 | INFO  | Model-Invoker-8          | 2021-08-13 16:02:04,455 | com.ca.im.portal.services.model.ModelImpl                        
INFO   | jvm 1    | 2021/08/13 16:02:04 |       | Model 30002_2: viewTree.render
INFO   | jvm 1    | 2021/08/13 16:02:04 | javax.xml.ws.soap.SOAPFaultException: Expected 1 request attribute, but found 2

Environment

All supported DX NetOps Performance Management releases r20.2.x and older.

Cause

The "Instana - APM for Microservice Applications agent" is running on the Portal web server.

Resolution

Stop the Instana agent service running on the Portal web server. Ensure it does not restart and remains shut down.

Normally a restart of Performance Management Portal web services is not needed to resolve the issue, just shutting down the Instana agent service.

This is resolved starting with the r21.2.1 release of DX NetOps Performance Management via defect DE486384. Upgrade to prevent this issue, allowing use of the Instana agent.