Workload Automation dSeries (DE): LDAP timeouts
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Workload Automation dSeries (DE): LDAP timeouts

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Article ID: 204302

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Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

Workload Automation DE disconnects from LDAP and may show these message in logs and console.

Unable to connect to LDAP server, configuration name: CONNECTION1234
Cause: javax.naming.CommunicationException: ldap.example.com:636 [Root exception is java.net.SocketTimeoutException: Read timed out]

 

Environment

Release : 12.x

Component : CA WORKLOAD AUTOMATION DE (DSERIES)

Cause

The time out is related to network.  This may also be due to misconfigured DNS and hostname.  

Resolution

Make sure the DNS and hostname are properly setup.

If the DE is connecting to load balancing setup then all ports and firewalls must allow the LDAP and LDAPS ports.