Unable to open Admin Console with error Address already in use: bind
search cancel

Unable to open Admin Console with error Address already in use: bind

book

Article ID: 204295

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Symptoms:

- Admin Console will not load

- pages at http://(primary hub)/uimhome and http://(primary hub)/adminconsoleapp both return 404/page not found

wasp.log shows:

Dec 01 15:39:42:301 ERROR [main, org.apache.catalina.util.LifecycleBase] handleSubClassException() Failed to initialize component [Connector[HTTP/1.1-80]]
Dec 01 15:39:42:302 ERROR [main, org.apache.catalina.util.LifecycleBase] org.apache.catalina.LifecycleException: Protocol handler initialization failed
 at org.apache.catalina.connector.Connector.initInternal(Connector.java:1042)
 at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
 at org.apache.catalina.core.StandardService.initInternal(StandardService.java:533)
 at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
 at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:1057)
 at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
 at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:173)
 at org.apache.catalina.startup.Tomcat.start(Tomcat.java:486)
 at com.nimsoft.nimbus.probe.service.wasp.Probe.doit(Probe.java:712)
 at com.nimsoft.nimbus.probe.service.wasp.Probe.main(Probe.java:115)
Caused by: java.net.BindException: Address already in use: bind

 

 

Environment

Release : UIM 20.3/20.4/23.4+

Component : UIM - ADMIN_CONSOLE

Cause

Port 80 in use by another application such as Windows HTTP Service

Resolution

Options for resolution:

  • using Raw Configure, set the value of "http_port" for the wasp probe (wasp.cfg <setup> section) to something other than port 80
  • determine what application is using port 80 and stop/reconfigure it

 

 

Additional Information