UIM Robots Not Reconnecting to Primary Hub
search cancel

UIM Robots Not Reconnecting to Primary Hub

book

Article ID: 204236

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After upgraded to 20.3.

A few Robots not reconnecting to primary hub.  

error in controller log

Nov 25 07:58:03:938 [7232] Controller: Controller on XXXXXX port 48000 started
Nov 25 07:58:05:219 [7232] Controller: Hub (X.X.X.X) contact established
Nov 25 07:58:05:219 [7232] Controller: ControllerLogin request login failed X.X.X.X/48002 (login failed)
Nov 25 07:58:08:688 [7232] Controller: ControllerLogin request login failed X.X.X.X/48002 (login failed)
Nov 25 08:13:16:228 [7232] Controller: failed to send alive to hub PrimaryHub(X.X.X.X) - not found
Nov 25 08:28:27:091 [7232] Controller: failed to send alive to hub PrimaryHub(X.X.X.X) - not found
Nov 25 08:33:49:374 [7232] Controller: Going down...
Nov 25 08:33:57:405 [7232] Controller: Down

Environment

Release : 20.3

Component : UIM - ROBOT_EXE

Cause

Corrupted information in Nimbus cache VM for robots

This may happen due AntiVirus Scan or too many files at the niscache folder

Resolution

Cleared the Nimbus cache ( Niscache) on all the VM’s

Windows:

1. Stop the Nimsoft Robot Watcher Service.
2. Locate the folder <Nimsoft Install>\Nimsoft\niscache\ (usually C:\Program Files (x86)\Nimsoft\niscache)
3. Delete all the files found in this folder, leaving the empty "niscache" folder behind.
         The cache files contain device registration info unique to that robot. Hence, why we are deleting the contents.
4. Edit the file <Nimsoft Install>\robot\robot.cfg using a text editor.
5. Ensure that "robotip" and "robotname" are set to a blank value.

Linux:

1. Stop the nimbus service by executing:  <Nimsoft Install>nimsoft/bin/niminit/stop.  (usually /opt/nimsoft/bin/)
2. Locate the folder <Nimsoft Install>\Nimsoft\niscache\ (e.g. /opt/nimsoft/niscache)
3.Delete all the files found in this folder, leaving the empty "niscache" folder behind.
     The cache files contain device registration info unique to that robot. Hence, why we are deleting the contents.
4. Edit the file <Nimsoft Install>\robot\robot.cfg using a text editor.
5. Ensure that "robotip" and "robotname" are set to a blank value.

Once the robot service is restarted on the target system, it will automatically generate a new device ID for itself and re-populate the niscache folder with metric files appropriate to that system.