Unexpected Server error when logging in to Endpoint Protection Manager with FIPS mode enabled
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Unexpected Server error when logging in to Endpoint Protection Manager with FIPS mode enabled

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Article ID: 204184

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Following a repair of Symantec Endpoint Protection Manager (SEPM), "Unexpected Server Error" is encountered when logging in to SEPM.  The following error can be seen in the scm-ui (located in TEMP directory):

 

Nov 25, 2020 1:50:17 PM  STDOUT: NoSuchProviderException Exception in getting MessageDigest.getInstance in FIPS Mode: no such provider: Symantec
Nov 25, 2020 1:50:17 PM GUIManager INFO: Unexpected server error. ErrorCode: 0x10010000
Nov 25, 2020 1:50:17 PM  STDOUT: GUIManager>> preparePostRequestHttpURLConnectionForLogin>> CommunicationException: Unexpected server error. ErrorCode: 0x10010000

or 

2022-04-20 12:28:04.202 THREAD 26 SEVERE: SemServiceManager> getServiceStatus>> Error code from sc query: 1060

 

Nov 25, 2020 1:50:25 PM  STDOUT: ServerCertUtil> readCreateStorePasswd>> Unable to read the Storepasswd from file: E:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat\conf\server.xml

Environment

Release :SEP 14.x

 

Cause

FIPS implementation was damaged during the repair, but remains enabled.  

Resolution

Disable and re-enable FIPS mode:

  1. As administrator, run the FIPSMode-Disable.bat file from Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\bin
  2. After FIPS mode has been disabled, re-enable it by running FIPSMode-Enable.bat which is located in the same directory.
  3. Run upgrade.bat.  location <SEPM>\bin\upgrade.bat.