DX OI - OIConnector not connecting when NetOps Portal user and password changes
search cancel

DX OI - OIConnector not connecting when NetOps Portal user and password changes

book

Article ID: 204144

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After changing the admin's user password on NetOps Portal because it is expired, the OIConnector cannot connect to NetOps Portal anymore.

In the OIconnector log can see these messages:
....
ERROR [2020-11-27 12:42:12,213] [WrapperSimpleAppMain] [OIIntegration] - [EVENT UNSPECIFIED Anonymous:null@unknown -> /com.ca.im.oinet.connector.OIIntegration] No response from webservice - unable to configure data sources
WARN  [2020-11-27 12:42:12,230] [WrapperSimpleAppMain] [OIIntegration] - [EVENT UNSPECIFIED Anonymous:null@unknown -> /com.ca.im.oinet.connector.OIIntegration] Unable to determine CA Performance Center version
....

and in PCService.log on NetOps Portal server:
....
ERROR | qtp19190116-38180        | 2020-11-27 12:42:12,138 | com.ca.im.portal.services.util.BasicAuthInterceptor
      | HTTP 403: User=admin, enabled=true, requestURI=/pc/center/webservice/status/registration
ERROR | qtp19190116-38236        | 2020-11-27 12:42:12,182 | com.ca.im.portal.services.util.BasicAuthInterceptor
      | HTTP 403: User=admin, enabled=true, requestURI=/pc/center/webservice/status/registration
ERROR | qtp19190116-38180        | 2020-11-27 12:42:12,209 | com.ca.im.portal.services.util.BasicAuthInterceptor
      | HTTP 403: User=admin, enabled=true, requestURI=/pc/center/webservice/datasources 
....

Environment

Release : 20.2

DIGITAL OPERATIONAL INTELLIGENCE - 1.3.2, 20.2

IM Reporting / Admin / Configuration

Cause

Changing the password on NetOps Portal side will brake the connection between OIConnector and NetOps Portal because the new password is not getting changed on the OIConnector_installation\conf\config.xml file.

 

Resolution

There is a password hash in the OIConnector_installation\conf\config.xml file for the NetOps Portal user and password. This needs to be updated accordingly.

Use an "Encode/Decode" tool to encode the new password from NetOps Portal and paste that encoded password in the OIConnector config.xml file. For example this tool can be used:
https://www.base64encode.org/

Additional Information

https://knowledge.broadcom.com/external/article/190815/dx-oi-troubleshooting-common-issues-and.html