couldn't find the key store file
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couldn't find the key store file

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Article ID: 204078

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

While executing the CLI command

capam_command capam=10.34.40.220 adminUserID=super cmdName=getErrorCodes

the following error is appearing

'couldn't find the key store file'

Initially, a Certificate was generated and added successfully to the keystore in a Windows 10 from which the connection was being made, and it was possible to run CLI commands.

Afterwards some changes were made to the Subject Alternate Name (SAN) of the CSR file so that the certificated had to be modified in the present box. Following this, it stopped working and it started throwing error 'couldn't find the key store file'. However, from other devices set up according to the documentation

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-access-manager/3-4/programming/credential-manager-remote-cli-and-java-api/install-and-set-up-the-remote-cli-and-java-api.html

the CLI commands started working

Environment

Issue was on PAM 3.4.1 but applicable to all versions.

 

Cause

The cause of the issue was that the environment variable PAM_CLI32 had a space at the end, highlighted below:

 

Resolution

Edited the environment variable CAPAM_CLI. Removed the space at the end. 

Command below execute successfully.

capam_command capam=10.34.40.220 adminUserID=super cmdName=getErrorCodes

 

Additional Information

Another similar issue discussed with the folder name containing the space.

https://community.broadcom.com/enterprisesoftware/blogs/prira01/2019/05/30/tech-tip-ca-privileged-access-manager-remote-cli-fails-to-find-the-keystore-file-on-windows?CommunityKey=3e91a086-c7b2-4bd0-9f8d-3493ed834111&tab=recentcommunityblogsdashboard

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