CPU Events are not seen in Performance Management
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CPU Events are not seen in Performance Management

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Article ID: 204061

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

CPU alarms violating a set threshold is not generating an alarm for a certain device, events missing.

CPU Events are not seen in Performance Management Performance Center web UI.

Memory Events are not seen in Performance Management Performance Center web UI.

Component Item Events are not seen in Performance Management Performance Center web UI.

This is seen for some Component Items but not all of them, some work fine.

Environment

DX NetOps Performance Management releases r20.2.2 and earlier

Cause

In the default configuration Component Items, those like CPU and Memory, aren't synchronized as individual items to Performance Center inventory. In that form Events for those items are raised against the device that manages them.

In the r20.2.1 and r20.2.2 releases of DX NetOps Performance Management these items were incorrectly marked as syncable. This takes place during Discovery update cycles when changes are found for the affected component items. When they need changes made, it is then that the incorrect syncable flag is set on the items. This is why we'll see the issue for some component items but not others on the same device or between different devices.

Because that is only part of the process to enable sync of these items to Performance Center Inventory, they remain unknown to the Event Manager.

The result of this is an inability for Event Manager to determine what Performance Center item it's been synced to raise the Event against. The Component item isn't found in Performance Center inventory as a properly synced item by Event Manager and it believe it is a properly synced item that should be found.

The end symptom is the Event and the items Data Aggregator Item ID is put in the Event Manager em MySql database unresolved_event_items table.

With it present in this table it will never be displayed in Performance Center.

Resolution

This is resolved via DE474142 in the DX NetOps Performance Management release r20.2.3.

To properly resolve this upgrade to the r20.2.3 or a newer release.

When resolving this there are two choices. Upgrade now and fix it, or work around it and upgrade later, fixing it after the upgrade at that time. The two choices are:

  1. Upgrade to r20.2.3 or newer release with the fix.
    • Post upgrade follow the steps provided by Support via Internal Only Knowledge Base Article ID 202492.
      • This is a process to clean up the items affected by removing the syncable mark they've been given that causes this.
    • Open a support case post upgrade for assistance with the clean up effort, ensuring this Knowledge Base article is referenced.
  2. Enable the sync of these components without upgrading.
    • This is done via instructions in KB How to synchronize unsynchronized Component element types to CA Performance Center.
    • There is benefit to keeping these component items synced to Performance Center as unique items.
      • Allows for Groups that contain only these items.
      • Helpful using those Groups in more targeted reports.
      • Helpful using those Groups in more targeted Threshold Rule application.
    • In the future, when an upgrade is performed it's possible to reverse this change of desired.
      • NOTE: Keeping it configured in this way can add load and resource usage to the system causing usage problems.
      • To reverse the change follow the instructions found in the Broadcom Internal Only Knowledge Base Article ID 145381.
        • To obtain those instructions open a new Support case referencing this Knowledge Base Article.
        • The process in the internal article helps to clean up items affected.
        • It works by removing the syncable mark they've been given as a workaround.

To validate this is the problem being faced:

  • Confirm that the system was not reconfigured to allow for synchronization of these Component Items.
  • Using the Data Aggregator ItemID for the target component item launch the following URL:
    • http://<DA_HOST>:8581/rest/syncable/<ItemID>
    • If a response is returned that looks like this, the item has been incorrectly marked as syncable.
    • A correct response for a component item that is not marked as syncable to Performance Center would return this.
      • This <DA_HostName> page can’t be found
        No webpage was found for the web address: http://<DA_HOST>:8581/rest/syncable/<ItemID>
        HTTP ERROR 404

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