CCI is issuing numerous CAS9899W "Heart Beat timeout" messages and appears to hang
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CCI is issuing numerous CAS9899W "Heart Beat timeout" messages and appears to hang

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Article ID: 204028

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Updated On:

Products

COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS COMMON PRODUCT SERVICES COMPONENT Common Services CA ECOMETER SERVER COMPONENT FOC Easytrieve Report Generator for Common Services INFOCAI MAINTENANCE IPC UNICENTER JCLCHECK COMMON COMPONENT LDAP SERVER FOR Z/OS Mainframe VM Product Manager CHORUS SOFTWARE MANAGER CA ON DEMAND PORTAL CA Service Desk Manager - Unified Self Service PAM CLIENT FOR LINUX ON MAINFRAME MAINFRAME CONNECTOR FOR LINUX ON MAINFRAME GRAPHICAL MANAGEMENT INTERFACE WEB ADMINISTRATOR FOR TOP SECRET Xpertware MF - MISC OLD CODES SERVICE ASSURE GENERIC UNISERVICE FOR CICS GENERIC UNISERVICE II Output Management Web Viewer

Issue/Introduction

While executing the Common Services CCITCPGW/CCISSLGW proc, the job hung causing CCI connections to fail.

The joblog shows multiple  CAS9899W "Heart Beat timeout" messages.  What can be causing this message and how can it be corrected?

Environment

Release : 14.1 and 15.0 

Component : CCI - COMMON COMMUNICATION INTERFACE 

Cause

The tasks that CCI was servicing had a WLM class of STCHI while ENF and CCI were running at STCMED.

The dispatching priority for CCI was too low which could have caused the wait.  

Resolution

Check the WLM class of both the ENF and CCI components. Ensure that the dispatching priority of both tasks are equal to or greater than any tasks they are servicing. 

Additional Information

Reference the Common Services z/OS documentation for the proper WLM settings when Configuring CCI.