CA Datacom Server TCPIP error 10061 WSAECONNREFUSED Connection Refused
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CA Datacom Server TCPIP error 10061 WSAECONNREFUSED Connection Refused

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Article ID: 203992

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Updated On:

Products

Datacom DATACOM - AD Datacom/DB INFOCAI MAINTENANCE

Issue/Introduction

A new ODBC data source is created for CA Datacom Server. Testing the connection fails with connection error:


[CA][ODBC CADATACOM/DB Driver][CA DATACOM/DB] TCP(10061)
WSAECONNREFUSED Connection Refused.

Environment

Release : 15.0

Component : CA DATACOM/Server

Cause

The error can be caused by:

  • A firewall blocking access either on the PC or on the mainframe
  • An incorrect host name 
  • Wrong port number.

Resolution

To resolve the problem check:

  • The local PC and mainframe firewall to see if they are blocking the connection, the IP address or port number.
  • The host name specified in the ODBC data source is correct.
  • The Port Number specified in the ODBC data source matches the port number specified in the mainframe server started task SVDBSPR. The port number is specified in the TCPIP_PORT parameter. The default is 5465. Check the SVDBSPR started task for the port number specified and also for any other error messages. 

 

 

Additional Information

See the CA Datacom Tools Documentation sections Configure Your ODBC Client, Start Up CA Datacom Server and Startup Options