Gateway 10 Policy manager issue
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Gateway 10 Policy manager issue

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Article ID: 203941

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Updated On:

Products

CA API Gateway API SECURITY CA API Gateway Precision API Monitoring Module for API Gateway (Layer 7) CA API Gateway Enterprise Service Manager (Layer 7) STARTER PACK-7 CA Microgateway

Issue/Introduction

My client upgraded the gateway from GW 9.1 to GW 10 CR02. When the user is trying to connect to Gateway via Policy Manager is having issues. The PM seems to be connected and you can also see the list of assertions on the top left; however, every features under View, File, Tools etc. within PM are greyed out.

 

Environment

Release : 10.0

Component : API GATEWAY

Cause

The underline problem is ..
java.lang.IllegalArgumentException: No enum constant com.l7tech.objectmodel.EntityType.WORK_QUEUE
at java.lang.Enum.valueOf(Enum.java:238)
at com.l7tech.objectmodel.EntityType.valueOf(Unknown Source)
... 129 more

Resolution

The underline problem is ..
java.lang.IllegalArgumentException: No enum constant com.l7tech.objectmodel.EntityType.WORK_QUEUE
at java.lang.Enum.valueOf(Enum.java:238)
at com.l7tech.objectmodel.EntityType.valueOf(Unknown Source)
... 129 more

The following resolved the customer's problem.

Search for and remove the references to work_queue in the security_zone table:
mysql> SELECT * FROM ssg.security_zone WHERE entity_type LIKE "%WORK_QUEUE%";
mysql> DELETE FROM ssg.security_zone WHERE entity_type LIKE "%WORK_QUEUE%";