WA Agent: SFTP job gets permission denied error
search cancel

WA Agent: SFTP job gets permission denied error

book

Article ID: 203799

calendar_today

Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

When an SFTP job runs it will complete but may get a 'Permission denied' error at the end.  When the WA Agent send commands such delete or rename at the end of the file transfer the user may not have permissions.

Environment

Release : 12.2

Component : CA WORKLOAD AUTOMATION DE (DSERIES)

Cause

The user connecting to remote host may not have permission to delete or rename the remote file.  Check for adequate space in the remote host.

Resolution

If the file transfer is completing but jobs fails because it is unable to delete, rename or move remote files then check permission.

Connect to remote host manually (ssh/sftp client) as the same user defined in the SFTP job and see if the user has proper permissions.