Insufficient system resources exist to complete the requested service error doesn't register in the WebUI
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Insufficient system resources exist to complete the requested service error doesn't register in the WebUI

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Article ID: 203658

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When running a publish job, the job is failing but the WebUI never updates that the job Failed
In the logs we see the following error.

2020-11-07 17:13:02.853 UTC [INFO ] [taskExecutor-1           ] --- [U:][M:][P:]                           c.c.t.p.l.TDMPublishLog:  ERROR: Publish failed for job 5214, java.io.FileNotFoundException: C:\Program Files\CA\CA Test Data Manager Portal\tomcat\webapps\TDMPublisherService\WEB-INF\lib\accessors-smart-1.2.jar (Insufficient system resources exist to complete the requested service)

What is causing this and how can we resolve this?

Environment

TDM Portal 4.
CA Test Data Manager

Cause

The portal is running out of memory and crashing.
This is causing the job to fail and the UI not to update.

Resolution

Increase the memory for the portal.

TDM Portal: How to Increase JVM Memory
https://knowledge.broadcom.com/external/article?articleId=10602