UIM alert history changes after oracle probe restart
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UIM alert history changes after oracle probe restart

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Article ID: 203618

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We are performing database remote monitoring via the oracle probe.

We have noticed that almost every time the probe is restarted the history of the alarm is deleted to the restart time and the time of arrival also changes as can be seen below (when we performed some changes and restarted the probe).

This is causing the issues as this data is propagated to different systems, in the instance of Spectrum it also updates the timestamp to when the restart was performed as can be seen below.

Spectrum OneClick console GUI:

The problem here is that this is done for all oracle related alarms and there is no way to know when the issue really first occurred meaning that there can be incorrect reporting.

Could you please explain the reason why this is happening, if it is expected, and if so what can we do to change this so that the arrival time of an oracle alert is the actual time that of occurrence.

Environment

Release : Any release of oracle probe

Component : UIM - ORACLE

Cause

Clear alarms on restart option is enabled in the environment:

 

Resolution

Perform the below steps (from Infrastructure Manager):

1. Launch the oracle Probe GUI (double click the probe): 

2. Uncheck Clear alarms on restart, click on Apply:

3. Click on Yes:


 
4. Click on OK:

5(a) Perform a cold-restart, i.e. right click the oracle probe and select Deactivate:

 

5(b) right click the oracle probe and select Activate:

6. Once the above changes have been made, restart the probe to verify the alarms history does not change.

 

Additional Information

For documentation on oracle probe please click:

Oracle probe documentation

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